aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_dir/Makefile.am
diff options
context:
space:
mode:
authorneonloop2021-10-20 14:54:27 +0000
committerneonloop2021-10-20 14:54:27 +0000
commitea1947ffcc606d757357398b24e74a3f4ecefa07 (patch)
tree2031b8d4fc4c61063c710a7148378f57e662efbd /modules/mod_dir/Makefile.am
downloadbennugd-ea1947ffcc606d757357398b24e74a3f4ecefa07.tar.gz
bennugd-ea1947ffcc606d757357398b24e74a3f4ecefa07.tar.bz2
bennugd-ea1947ffcc606d757357398b24e74a3f4ecefa07.zip
Initial commit from steward-fu releasemain
Diffstat (limited to 'modules/mod_dir/Makefile.am')
-rw-r--r--modules/mod_dir/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_dir/Makefile.am b/modules/mod_dir/Makefile.am
new file mode 100644
index 0000000..a3a7ad3
--- /dev/null
+++ b/modules/mod_dir/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_dir.la
+
+libmod_dir_la_SOURCES = mod_dir.c
+libmod_dir_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include
+libmod_dir_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_dir_la_LIBADD = $(COMMON_LDFLAGS) -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_dir.la
+