summaryrefslogtreecommitdiff
path: root/setup/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2009-11-19 21:49:13 +0000
committerSimon Howard2009-11-19 21:49:13 +0000
commit43b0dbd272da1d590797d2974e94413971131129 (patch)
treea4deab2b5fe6a50d66966a792a103563a4464103 /setup/Makefile.am
parente62fdd771f01ef7b50fe3cb8f456eae5d7db3748 (diff)
downloadchocolate-doom-43b0dbd272da1d590797d2974e94413971131129.tar.gz
chocolate-doom-43b0dbd272da1d590797d2974e94413971131129.tar.bz2
chocolate-doom-43b0dbd272da1d590797d2974e94413971131129.zip
Rework the OS X MIDI disabling code, as SDL_mixer 1.2.11 fixes the
crash. Check and disable MIDI by default if using an older version of SDL on OS X. Subversion-branch: /trunk/chocolate-doom Subversion-revision: 1730
Diffstat (limited to 'setup/Makefile.am')
-rw-r--r--setup/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup/Makefile.am b/setup/Makefile.am
index af80d525..92b4e394 100644
--- a/setup/Makefile.am
+++ b/setup/Makefile.am
@@ -1,7 +1,7 @@
gamesdir = $(prefix)/games
-AM_CFLAGS = -I../textscreen -I../src
+AM_CFLAGS = -I../textscreen -I../src @SDLMIXER_CFLAGS@
games_PROGRAMS = chocolate-setup
@@ -34,6 +34,7 @@ endif
chocolate_setup_LDADD = \
../wince/libc_wince.a \
../textscreen/libtextscreen.a \
+ @SDLMIXER_LIBS@ \
@LDFLAGS@
.rc.o: