aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorptitSeb2017-12-06 17:06:17 +0100
committerptitSeb2017-12-06 17:06:17 +0100
commit9445c69a5148b9ef070aca2e73d94b38e9f4ce79 (patch)
tree9c9d38cd39d5a6f27e39d6f5a782e3e56c328026 /CMakeLists.txt
parentc5e4535f9ac06c25bd37529b351fbbf927e82683 (diff)
downloadhydracastlelabyrinth-9445c69a5148b9ef070aca2e73d94b38e9f4ce79.tar.gz
hydracastlelabyrinth-9445c69a5148b9ef070aca2e73d94b38e9f4ce79.tar.bz2
hydracastlelabyrinth-9445c69a5148b9ef070aca2e73d94b38e9f4ce79.zip
Added ODROID support (thanks to @meveric)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c2a26c..49927f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,7 @@
cmake_minimum_required(VERSION 2.8)
option(PANDORA "Set to ON if targeting an OpenPandora device" ${PANDORA})
+option(ODROID "Set to ON if targeting an ODroid device" ${ODROID})
option(PYRA "Set to ON if targeting an DragonBox Pyra device" ${PANDORA})
option(CHIP "Set to ON if targeting an PocketCHIP device" ${PANDORA})
@@ -14,7 +15,10 @@ endif()
if(CHIP)
add_definitions(-DCHIP)
endif()
-
+if(ODROID)
+ add_definitions(-DODROID)
+ set (EXTRA_LIBS ${EXTRA_LIBS} X11)
+endif()
#create a _SDL2 later?
add_definitions(-D_SDL)