aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBastien Nocera2002-05-10 17:44:16 +0000
committerBastien Nocera2002-05-10 17:44:16 +0000
commit36acc99ae1631433f286dde703c89f7fe95679c7 (patch)
tree58ba7b2f71343b28dc8c2c3007f7fc879cbdcef3 /debian/rules
parentc72ceda700dff760a90ff701aaf32a37829be9eb (diff)
downloadscummvm-rg350-36acc99ae1631433f286dde703c89f7fe95679c7.tar.gz
scummvm-rg350-36acc99ae1631433f286dde703c89f7fe95679c7.tar.bz2
scummvm-rg350-36acc99ae1631433f286dde703c89f7fe95679c7.zip
- removed wrapper script, re-added missing debian files (ooops!), added a README.Debian with some info about the config file for Ender
svn-id: r4269
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules48
1 files changed, 48 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000000..b05473cabc
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+
+export DH_COMPAT=3
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+build:
+ dh_testdir
+ $(MAKE)
+
+clean:
+ dh_testdir
+ dh_testroot
+ -$(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ install -m0777 scummvm $(CURDIR)/debian/scummvm/usr/games/scummvm
+ install -m0644 scummvm.6 \
+ $(CURDIR)/debian/scummvm/usr/share/man/man6
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs
+ dh_installmanpages scummvm.6
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-arch
+.PHONY: build clean binary-arch binary install