aboutsummaryrefslogtreecommitdiff
path: root/modules/libsdlhandler/Makefile.am
diff options
context:
space:
mode:
authorneonloop2021-10-20 14:54:27 +0000
committerneonloop2021-10-20 14:54:27 +0000
commitea1947ffcc606d757357398b24e74a3f4ecefa07 (patch)
tree2031b8d4fc4c61063c710a7148378f57e662efbd /modules/libsdlhandler/Makefile.am
downloadbennugd-main.tar.gz
bennugd-main.tar.bz2
bennugd-main.zip
Initial commit from steward-fu releasemain
Diffstat (limited to 'modules/libsdlhandler/Makefile.am')
-rw-r--r--modules/libsdlhandler/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/libsdlhandler/Makefile.am b/modules/libsdlhandler/Makefile.am
new file mode 100644
index 0000000..2c0f0b0
--- /dev/null
+++ b/modules/libsdlhandler/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libsdlhandler.la
+
+libsdlhandler_la_SOURCES = libsdlhandler.c
+libsdlhandler_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include
+libsdlhandler_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libsdlhandler_la_LIBADD = $(COMMON_LDFLAGS) $(SDL_LIBS)
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libsdlhandler.la
+