aboutsummaryrefslogtreecommitdiff
path: root/3rdparty/des-4.04b/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/des-4.04b/Makefile.PL')
-rw-r--r--3rdparty/des-4.04b/Makefile.PL14
1 files changed, 14 insertions, 0 deletions
diff --git a/3rdparty/des-4.04b/Makefile.PL b/3rdparty/des-4.04b/Makefile.PL
new file mode 100644
index 0000000..b54a243
--- /dev/null
+++ b/3rdparty/des-4.04b/Makefile.PL
@@ -0,0 +1,14 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile being created.
+&writeMakefile(
+ 'potential_libs' => '', # e.g., '-lm'
+ 'INC' => '', # e.g., '-I/usr/include/other'
+ 'DISTNAME' => 'DES',
+ 'VERSION' => '0.1',
+ 'DEFINE' => '-DPERL5',
+ 'OBJECT' => 'DES.o cbc_cksm.o cbc_enc.o ecb_enc.o pcbc_enc.o \
+ rand_key.o set_key.o str2key.o \
+ enc_read.o enc_writ.o fcrypt.o cfb_enc.o \
+ ecb3_enc.o ofb_enc.o cbc3_enc.o des_enc.o',
+ );