aboutsummaryrefslogtreecommitdiff
path: root/core/bgdrtm/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'core/bgdrtm/src/Makefile.am')
-rw-r--r--core/bgdrtm/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/core/bgdrtm/src/Makefile.am b/core/bgdrtm/src/Makefile.am
new file mode 100644
index 0000000..642c4a4
--- /dev/null
+++ b/core/bgdrtm/src/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libbgdrtm.la
+
+libbgdrtm_la_SOURCES = fmath.c dcbr.c sysprocs.c strings.c dirs.c copy.c misc.c instance.c interpreter.c varspace_file.c ../../common/debug.c ../../common/b_crypt.c ../../common/files.c ../../common/xctype.c
+libbgdrtm_la_CFLAGS = $(COMMON_CFLAGS) $(ZLIB_CFLAGS) -I../../include -I../include -D__BGDRTM__ -DDEBUG
+libbgdrtm_la_LDFLAGS = -s -module -no-undefined -avoid-version -export-all-symbols
+libbgdrtm_la_LIBADD = $(COMMON_LDFLAGS) $(ZLIB_LIBS) $(CRYPT_LDFLAGS) -lm
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libbgdrtm.la
+