aboutsummaryrefslogtreecommitdiff
path: root/modules/libblit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libblit/Makefile.am')
-rw-r--r--modules/libblit/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/libblit/Makefile.am b/modules/libblit/Makefile.am
new file mode 100644
index 0000000..89b63ec
--- /dev/null
+++ b/modules/libblit/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libblit.la
+
+libblit_la_SOURCES = libblit.c g_blit.c g_pixel.c
+libblit_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I. -I../libgrbase/
+libblit_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libblit_la_LIBADD = $(COMMON_LDFLAGS) $(SDL_LIBS) -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm -L../libgrbase/.libs -lgrbase
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libblit.la