aboutsummaryrefslogtreecommitdiff
path: root/modules/libdraw/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libdraw/Makefile.am')
-rw-r--r--modules/libdraw/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/libdraw/Makefile.am b/modules/libdraw/Makefile.am
new file mode 100644
index 0000000..07276b5
--- /dev/null
+++ b/modules/libdraw/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libdraw.la
+
+libdraw_la_SOURCES = libdraw.c
+libdraw_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I. -I../libgrbase/ -I../libblit/
+libdraw_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libdraw_la_LIBADD = $(COMMON_LDFLAGS) -L../libblit/.libs -lblit -L../libgrbase/.libs -lgrbase
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libdraw.la