aboutsummaryrefslogtreecommitdiff
path: root/modules/libfont/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libfont/Makefile.am')
-rw-r--r--modules/libfont/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/libfont/Makefile.am b/modules/libfont/Makefile.am
new file mode 100644
index 0000000..2e2a64d
--- /dev/null
+++ b/modules/libfont/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libfont.la
+
+libfont_la_SOURCES = libfont.c
+libfont_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I. -I../libgrbase/
+libfont_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libfont_la_LIBADD = $(COMMON_LDFLAGS) -L../libgrbase/.libs -lgrbase
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libfont.la