aboutsummaryrefslogtreecommitdiff
path: root/modules/libgrbase/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libgrbase/Makefile.am')
-rw-r--r--modules/libgrbase/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/libgrbase/Makefile.am b/modules/libgrbase/Makefile.am
new file mode 100644
index 0000000..f582d8a
--- /dev/null
+++ b/modules/libgrbase/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libgrbase.la
+
+libgrbase_la_SOURCES = g_bitmap.c g_clear.c g_grlib.c g_pal.c g_blendop.c g_conversion.c libgrbase.c
+libgrbase_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include -I.
+libgrbase_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libgrbase_la_LIBADD = $(COMMON_LDFLAGS)
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libgrbase.la