aboutsummaryrefslogtreecommitdiff
path: root/modules/libjoy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libjoy/Makefile.am')
-rw-r--r--modules/libjoy/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/libjoy/Makefile.am b/modules/libjoy/Makefile.am
new file mode 100644
index 0000000..83519d8
--- /dev/null
+++ b/modules/libjoy/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libjoy.la
+
+libjoy_la_SOURCES = libjoy.c
+libjoy_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include
+libjoy_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libjoy_la_LIBADD = $(COMMON_LDFLAGS) $(SDL_LIBS) -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libjoy.la
+