aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_draw/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_draw/Makefile.am')
-rw-r--r--modules/mod_draw/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_draw/Makefile.am b/modules/mod_draw/Makefile.am
new file mode 100644
index 0000000..a075f8d
--- /dev/null
+++ b/modules/mod_draw/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_draw.la
+
+libmod_draw_la_SOURCES = mod_draw.c
+libmod_draw_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include -I. -I../libdraw/ -I../librender/ -I../libblit/ -I../libgrbase/
+libmod_draw_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_draw_la_LIBADD = $(COMMON_LDFLAGS) -L$(BGD_PATH)/bgdrtm/src/.libs -L../libdraw/.libs -ldraw -L../librender/.libs -lrender -L../libblit/.libs -lblit -L../libgrbase/.libs -lgrbase
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_draw.la
+