aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_flic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_flic/Makefile.am')
-rw-r--r--modules/mod_flic/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_flic/Makefile.am b/modules/mod_flic/Makefile.am
new file mode 100644
index 0000000..4baafc1
--- /dev/null
+++ b/modules/mod_flic/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_flic.la
+
+libmod_flic_la_SOURCES = mod_flic.c
+libmod_flic_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include -I. -I../librender/ -I../libblit/ -I../libgrbase/
+libmod_flic_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_flic_la_LIBADD = $(COMMON_LDFLAGS) $(SDL_LIBS) -L$(BGD_PATH)/bgdrtm/src/.libs -L../librender/.libs -lrender -L../libblit/.libs -lblit -L../libgrbase/.libs -lgrbase -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_flic.la
+