aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_joy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_joy/Makefile.am')
-rw-r--r--modules/mod_joy/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_joy/Makefile.am b/modules/mod_joy/Makefile.am
new file mode 100644
index 0000000..182277b
--- /dev/null
+++ b/modules/mod_joy/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_joy.la
+
+libmod_joy_la_SOURCES = mod_joy.c
+libmod_joy_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I../libjoy
+libmod_joy_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_joy_la_LIBADD = $(COMMON_LDFLAGS) -L../libjoy/.libs -ljoy -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_joy.la
+