aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_map/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_map/Makefile.am')
-rw-r--r--modules/mod_map/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/mod_map/Makefile.am b/modules/mod_map/Makefile.am
new file mode 100644
index 0000000..a6874bb
--- /dev/null
+++ b/modules/mod_map/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_map.la
+
+libmod_map_la_SOURCES = file_pcx.c file_png.c file_map.c file_pal.c file_fpg.c file_fnt.c mod_map.c
+libmod_map_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I. -I../libbgload/ -I../librender/ -I../libfont/ -I../libblit/ -I../libvideo/ -I../libgrbase/
+libmod_map_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_map_la_LIBADD = $(COMMON_LDFLAGS) $(PNGLIBS) $(SDL_LIBS) -L../libbgload/.libs -lbgload -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm -L../librender/.libs -lrender -L../libfont/.libs -lfont -L../libblit/.libs -lblit -L../libvideo/.libs -lvideo -L../libgrbase/.libs -lgrbase -lpng
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_map.la