aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_path/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_path/Makefile.am')
-rw-r--r--modules/mod_path/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_path/Makefile.am b/modules/mod_path/Makefile.am
new file mode 100644
index 0000000..430c8e2
--- /dev/null
+++ b/modules/mod_path/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_path.la
+
+libmod_path_la_SOURCES = mod_path.c
+libmod_path_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include -I$(BGD_PATH)/bgdrtm/include -I../libgrbase/
+libmod_path_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_path_la_LIBADD = $(COMMON_LDFLAGS) -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm -L../libgrbase/.libs -lgrbase
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_path.la
+