aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_rand/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_rand/Makefile.am')
-rw-r--r--modules/mod_rand/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_rand/Makefile.am b/modules/mod_rand/Makefile.am
new file mode 100644
index 0000000..a995599
--- /dev/null
+++ b/modules/mod_rand/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_rand.la
+
+libmod_rand_la_SOURCES = mod_rand.c
+libmod_rand_la_CFLAGS = $(COMMON_CFLAGS) -I$(BGD_PATH)/include
+libmod_rand_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_rand_la_LIBADD = $(COMMON_LDFLAGS)
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_rand.la
+