aboutsummaryrefslogtreecommitdiff
path: root/modules/mod_timers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/mod_timers/Makefile.am')
-rw-r--r--modules/mod_timers/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/mod_timers/Makefile.am b/modules/mod_timers/Makefile.am
new file mode 100644
index 0000000..265a8f7
--- /dev/null
+++ b/modules/mod_timers/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies foreign
+
+lib_LTLIBRARIES = libmod_timers.la
+
+libmod_timers_la_SOURCES = mod_timers.c
+libmod_timers_la_CFLAGS = $(COMMON_CFLAGS) $(SDL_CFLAGS) -I$(BGD_PATH)/include
+libmod_timers_la_LDFLAGS = -s -module -no-undefined -avoid-version
+libmod_timers_la_LIBADD = $(COMMON_LDFLAGS) $(SDL_LIBS) -L$(BGD_PATH)/bgdrtm/src/.libs -lbgdrtm
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libmod_timers.la
+