summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon Howard2009-07-13 00:52:26 +0000
committerSimon Howard2009-07-13 00:52:26 +0000
commit480a31094b7621dd7d65ec05a6e36964dca99b66 (patch)
tree11b218d674e828c12981d819b8f2396b680436df /configure.in
parent37db69b86bc5052901e250578e9c3920886d79ff (diff)
parente66653a8a67f3613344ae4ea30b37403d6ff17cf (diff)
downloadchocolate-doom-480a31094b7621dd7d65ec05a6e36964dca99b66.tar.gz
chocolate-doom-480a31094b7621dd7d65ec05a6e36964dca99b66.tar.bz2
chocolate-doom-480a31094b7621dd7d65ec05a6e36964dca99b66.zip
Merge from trunk.
Subversion-branch: /branches/opl-branch Subversion-revision: 1624
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3ee2e59e..7c31ced4 100644
--- a/configure.in
+++ b/configure.in
@@ -53,6 +53,19 @@ AC_CHECK_LIB(SDL_net,SDLNet_UDP_Send,[
exit -1
])
+# Windows CE build?
+
+WINDOWS_CE=false
+
+case "$host" in
+ *mingw32ce*|*cegcc*|*wince*)
+ CFLAGS="-I../wince $CFLAGS"
+ WINDOWS_CE=true
+ ;;
+ *)
+ ;;
+esac
+
AC_CHECK_HEADERS([linux/kd.h dev/isa/spkrio.h dev/speaker/speaker.h])
AC_CHECK_FUNCS(mmap sched_setaffinity ioperm)
@@ -61,6 +74,7 @@ AC_CHECK_LIB(samplerate, src_new)
AC_CHECK_TOOL(WINDRES, windres, )
+AM_CONDITIONAL(WINDOWS_CE, $WINDOWS_CE)
AM_CONDITIONAL(HAVE_WINDRES, test "$WINDRES" != "")
AM_CONDITIONAL(HAVE_PYTHON, $HAVE_PYTHON)
@@ -86,6 +100,7 @@ AC_DEFUN([AC_DATAROOTDIR_CHECKED])
AC_OUTPUT([
Makefile
+wince/Makefile
textscreen/Makefile
textscreen/examples/Makefile
setup/Makefile
@@ -94,6 +109,7 @@ opl/Makefile
opl/examples/Makefile
src/Makefile
pcsound/Makefile
+pkg/wince/Makefile
src/resource.rc
src/doom-screensaver.desktop
setup/setup-res.rc