summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2013-09-15 22:41:33 +0000
committerSimon Howard2013-09-15 22:41:33 +0000
commitb0a0f90cd9b976a39ed7945fe09e1d6f96899f68 (patch)
treee2e7a1669adfc14347cfc3d181bf3536dd7a7183 /man/Makefile.am
parentd2e79e322ae8875f471b8434445ba6a9432e9627 (diff)
downloadchocolate-doom-b0a0f90cd9b976a39ed7945fe09e1d6f96899f68.tar.gz
chocolate-doom-b0a0f90cd9b976a39ed7945fe09e1d6f96899f68.tar.bz2
chocolate-doom-b0a0f90cd9b976a39ed7945fe09e1d6f96899f68.zip
Rework documentation system to generate INSTALL files tailored for the
different games. Subversion-branch: /branches/v2-branch Subversion-revision: 2652
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am25
1 files changed, 18 insertions, 7 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 5eb787f1..17ffbe22 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -27,8 +27,9 @@ man_MANS=chocolate-server.6 \
strife.cfg.5 \
chocolate-strife.cfg.5
-nodist_doc_DATA=INSTALL CMDLINE.doom CMDLINE.heretic \
- CMDLINE.hexen CMDLINE.strife
+nodist_doc_DATA=INSTALL \
+ INSTALL.doom INSTALL.heretic INSTALL.hexen INSTALL.strife \
+ CMDLINE.doom CMDLINE.heretic CMDLINE.hexen CMDLINE.strife
@@ -43,9 +44,11 @@ chocolate-doom.cfg.5: ../src extra.cfg.template
./docgen -g doom -m extra.cfg.template \
-c extended ../src/m_config.c > $@
-CMDLINE.doom : ../src ../src/doom
+CMDLINE.doom : CMDLINE.template ../src ../src/doom
./docgen -p CMDLINE.template ../src/ ../src/doom/ > $@
+INSTALL.doom: INSTALL.template
+ ./simplecpp -DDOOM -DPRECOMPILED < INSTALL.template > $@
chocolate-heretic.6: ../src $(MANPAGE_GEN_FILES)
@@ -59,9 +62,12 @@ chocolate-heretic.cfg.5: ../src extra.cfg.template
./docgen -g heretic -m extra.cfg.template \
-c extended ../src/m_config.c > $@
-CMDLINE.heretic : ../src ../src/heretic
+CMDLINE.heretic : CMDLINE.template ../src ../src/heretic
./docgen -p CMDLINE.template ../src/ ../src/heretic/ > $@
+INSTALL.heretic: INSTALL.template
+ ./simplecpp -DHERETIC -DPRECOMPILED < INSTALL.template > $@
+
chocolate-hexen.6: ../src $(MANPAGE_GEN_FILES)
./docgen -g hexen -m hexen.template ../src ../src/hexen > $@
@@ -74,9 +80,11 @@ chocolate-hexen.cfg.5: ../src extra.cfg.template
./docgen -g hexen -m extra.cfg.template \
-c extended ../src/m_config.c > $@
-CMDLINE.hexen : ../src ../src/hexen
+CMDLINE.hexen : CMDLINE.template ../src ../src/hexen
./docgen -p CMDLINE.template ../src/ ../src/hexen/ > $@
+INSTALL.hexen: INSTALL.template
+ ./simplecpp -DHEXEN -DPRECOMPILED < INSTALL.template > $@
chocolate-strife.6: ../src $(MANPAGE_GEN_FILES)
@@ -90,13 +98,16 @@ chocolate-strife.cfg.5: ../src extra.cfg.template
./docgen -g strife -m extra.cfg.template \
-c extended ../src/m_config.c > $@
-CMDLINE.strife : ../src ../src/strife
+CMDLINE.strife : CMDLINE.template ../src ../src/strife
./docgen -p CMDLINE.template ../src/ ../src/strife/ > $@
+INSTALL.strife: INSTALL.template
+ ./simplecpp -DSTRIFE -DPRECOMPILED < INSTALL.template > $@
INSTALL: INSTALL.template
- ./simplecpp -DPRECOMPILED < INSTALL.template > $@
+ ./simplecpp -DDOOM -DHERETIC -DHEXEN -DSTRIFE \
+ -DPRECOMPILED < INSTALL.template > $@
endif