summaryrefslogtreecommitdiff
path: root/pkg/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2010-01-05 15:52:12 +0000
committerSimon Howard2010-01-05 15:52:12 +0000
commit860a17497bdc189f78f5a0bca000a0451d5ae624 (patch)
tree9dfe693c8cf461a262e9aef89e4011d3e9e842af /pkg/Makefile.am
parent37325bbfc1f71111715cf2f4ef2918b6cc5c0ff1 (diff)
downloadchocolate-doom-860a17497bdc189f78f5a0bca000a0451d5ae624.tar.gz
chocolate-doom-860a17497bdc189f78f5a0bca000a0451d5ae624.tar.bz2
chocolate-doom-860a17497bdc189f78f5a0bca000a0451d5ae624.zip
Move config.make up to pkg/ directory. Use static makefiles to generate
all packages, rather than dynamically generated makefiles. Add pkg/osx to dist. Make OS X staging directory depend on top level documentation files. Generate CMDLINE as part of standard build if it is not already present. Set svn:ignore properties. Subversion-branch: /trunk/chocolate-doom Subversion-revision: 1790
Diffstat (limited to 'pkg/Makefile.am')
-rw-r--r--pkg/Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/pkg/Makefile.am b/pkg/Makefile.am
index 66cb9ba0..9a607ee8 100644
--- a/pkg/Makefile.am
+++ b/pkg/Makefile.am
@@ -1,3 +1,29 @@
-DIST_SUBDIRS=wince win32
+OSX_FILES= \
+osx/app-skeleton/Contents/PkgInfo \
+osx/app-skeleton/Contents/Resources/128x128.png \
+osx/app-skeleton/Contents/Resources/app.icns \
+osx/app-skeleton/Contents/Resources/launcher.nib/classes.nib \
+osx/app-skeleton/Contents/Resources/launcher.nib/info.nib \
+osx/app-skeleton/Contents/Resources/launcher.nib/keyedobjects.nib \
+osx/GNUmakefile \
+osx/Info.plist.in \
+osx/cp-with-libs \
+osx/main.m \
+osx/AppController.m osx/AppController.h \
+osx/Execute.m osx/Execute.h \
+osx/IWADController.m osx/IWADController.h \
+osx/IWADLocation.m osx/IWADLocation.h \
+osx/LauncherManager.m osx/LauncherManager.h
+
+WINCE_FILES= \
+wince/GNUmakefile \
+wince/wince-cab.cfg \
+wince/wince-cabgen
+
+WIN32_FILES= \
+win32/GNUmakefile \
+win32/README
+
+EXTRA_DIST=$(OSX_FILES) $(WINCE_FILES) $(WIN32_FILES)