summaryrefslogtreecommitdiff
path: root/pkg/wince/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2009-06-21 19:33:35 +0000
committerSimon Howard2009-06-21 19:33:35 +0000
commit8777a9672ecaf308d974a9c36f6edab6ee65bf4b (patch)
treedf3012e2d1d6d2874f567485903ec0c360027713 /pkg/wince/Makefile.am
parent4981903f7c4f6d1e7dba74782afe1624ecb95685 (diff)
downloadchocolate-doom-8777a9672ecaf308d974a9c36f6edab6ee65bf4b.tar.gz
chocolate-doom-8777a9672ecaf308d974a9c36f6edab6ee65bf4b.tar.bz2
chocolate-doom-8777a9672ecaf308d974a9c36f6edab6ee65bf4b.zip
Add Makefile for building CAB files, dependency calculation.
Subversion-branch: /trunk/chocolate-doom Subversion-revision: 1607
Diffstat (limited to 'pkg/wince/Makefile.am')
-rw-r--r--pkg/wince/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/pkg/wince/Makefile.am b/pkg/wince/Makefile.am
new file mode 100644
index 00000000..13b48d2e
--- /dev/null
+++ b/pkg/wince/Makefile.am
@@ -0,0 +1,10 @@
+
+DEPS=$(shell ./wince-cabgen -d $(CONFIG_FILE))
+CONFIG_FILE=wince-cab.cfg
+OUTPUT_FILE=@PACKAGE_TARNAME@-@PACKAGE_VERSION@.cab
+
+noinst_DATA = $(OUTPUT_FILE)
+
+$(OUTPUT_FILE) : $(CONFIG_FILE) $(DEPS)
+ ./wince-cabgen $< $@
+