summaryrefslogtreecommitdiff
path: root/setup/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2008-11-21 18:03:06 +0000
committerSimon Howard2008-11-21 18:03:06 +0000
commitae18d8c4b6f7f918aa5ec496ca32899793cbe41e (patch)
treeed15c8dab41695f3b899590c4efbfec91a4426ee /setup/Makefile.am
parent9646b03b13d875289ce0270cacab67657684bd58 (diff)
downloadchocolate-doom-ae18d8c4b6f7f918aa5ec496ca32899793cbe41e.tar.gz
chocolate-doom-ae18d8c4b6f7f918aa5ec496ca32899793cbe41e.tar.bz2
chocolate-doom-ae18d8c4b6f7f918aa5ec496ca32899793cbe41e.zip
Move setup/ into src/ and merge with main codebase. Remove duplicated
code. Split out I_Endoom to separate i_endoom.c file. Subversion-branch: /branches/raven-branch Subversion-revision: 1384
Diffstat (limited to 'setup/Makefile.am')
-rw-r--r--setup/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/setup/Makefile.am b/setup/Makefile.am
deleted file mode 100644
index f845f853..00000000
--- a/setup/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-
-gamesdir = $(prefix)/games
-
-AM_CFLAGS = @SDL_CFLAGS@ -I../textscreen -I../src -DINSTALL_DIR="\"$(gamesdir)\""
-
-games_PROGRAMS = chocolate-setup
-
-chocolate_setup_LDADD = ../textscreen/libtextscreen.a @LDFLAGS@ @SDL_LIBS@
-SOURCE_FILES = \
- compatibility.c compatibility.h \
- configfile.c configfile.h \
- display.c display.h \
- joystick.c joystick.h \
- keyboard.c keyboard.h \
- m_argv.c m_argv.h \
- mainmenu.c \
- mouse.c mouse.h \
- multiplayer.c multiplayer.h \
- sound.c sound.h \
- execute.c execute.h \
- txt_joybinput.c txt_joybinput.h \
- txt_keyinput.c txt_keyinput.h \
- txt_mouseinput.c txt_mouseinput.h
-
-EXTRA_DIST= \
- setup_icon.c \
- setup-manifest.xml
-
-if HAVE_WINDRES
-chocolate_setup_SOURCES=$(SOURCE_FILES) setup-res.rc
-else
-chocolate_setup_SOURCES=$(SOURCE_FILES)
-endif
-
-.rc.o:
- $(WINDRES) $^ -o $@
-%.o : %.rc
- $(WINDRES) $^ -o $@
-
-if HAVE_PYTHON
-
-setup_icon.c : ../data/setup.ico
- ../data/convert-icon $^ $@
-
-endif
-