summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike Swanson2015-06-12 12:43:05 -0700
committerMike Swanson2015-08-29 16:18:34 -0700
commit79ef117aa867751110124fec843e0e406ddfe234 (patch)
tree74897d9e490efe9ca2b6004e2ef193266da03060 /src/Makefile.am
parent4b865a2a162023b7a7cdb8c7eba16af9c447ec9b (diff)
downloadchocolate-doom-79ef117aa867751110124fec843e0e406ddfe234.tar.gz
chocolate-doom-79ef117aa867751110124fec843e0e406ddfe234.tar.bz2
chocolate-doom-79ef117aa867751110124fec843e0e406ddfe234.zip
Add some preliminary *.appdata.xml files for software centers
This should resolve #406; the description text probably needs revisement, and we still need to compose images for the screenshots section.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1e54824c..78ee3bae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -217,6 +217,25 @@ EXTRA_DIST = \
doom-screensaver.desktop.in \
manifest.xml
+appdatadir = $(prefix)/share/appdata
+appdata_DATA = \
+ @PROGRAM_PREFIX@doom.appdata.xml \
+ @PROGRAM_PREFIX@heretic.appdata.xml \
+ @PROGRAM_PREFIX@hexen.appdata.xml \
+ @PROGRAM_PREFIX@strife.appdata.xml
+
+@PROGRAM_PREFIX@doom.appdata.xml : doom.appdata.xml
+ cp doom.appdata.xml $@
+
+@PROGRAM_PREFIX@heretic.appdata.xml : heretic.appdata.xml
+ cp heretic.appdata.xml $@
+
+@PROGRAM_PREFIX@hexen.appdata.xml : hexen.appdata.xml
+ cp hexen.appdata.xml $@
+
+@PROGRAM_PREFIX@strife.appdata.xml : strife.appdata.xml
+ cp strife.appdata.xml $@
+
appdir = $(prefix)/share/applications
app_DATA = \
@PROGRAM_PREFIX@doom.desktop \