summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2007-03-07 19:08:27 +0000
committerSimon Howard2007-03-07 19:08:27 +0000
commite434c7c10278a47fc686024fae04d361a0282ab8 (patch)
tree04bbcbcfe2c2f0cae269e0c16911615ecf51bf6f /src/Makefile.am
parentb96d0e706d15778c264f8e824343b050ea4a72d6 (diff)
downloadchocolate-doom-e434c7c10278a47fc686024fae04d361a0282ab8.tar.gz
chocolate-doom-e434c7c10278a47fc686024fae04d361a0282ab8.tar.bz2
chocolate-doom-e434c7c10278a47fc686024fae04d361a0282ab8.zip
Use native endianness for sound output, rather than always LSB. Add PC
speaker code! Subversion-branch: /trunk/chocolate-doom Subversion-revision: 844
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d34a5b17..53ef775c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,6 +22,8 @@ z_native.c z_zone.h
chocolate_server_SOURCES=$(DEDSERV_FILES)
chocolate_server_LDADD = @LDFLAGS@ @SDL_LIBS@ @SDLNET_LIBS@
+SUBDIRS=pcsound
+
SOURCE_FILES=\
am_map.c am_map.h \
deh_ammo.c \
@@ -62,6 +64,7 @@ hu_stuff.c hu_stuff.h \
i_main.c \
info.c info.h \
i_scale.c i_scale.h \
+i_pcsound.c i_pcsound.h \
i_sound.c i_sound.h \
i_system.c i_system.h \
i_timer.c i_timer.h \
@@ -138,7 +141,7 @@ else
chocolate_doom_SOURCES=$(SOURCE_FILES)
endif
-chocolate_doom_LDADD = ../textscreen/libtextscreen.a @LDFLAGS@ @SDL_LIBS@ @SDLMIXER_LIBS@ @SDLNET_LIBS@
+chocolate_doom_LDADD = ../textscreen/libtextscreen.a pcsound/libpcsound.a @LDFLAGS@ @SDL_LIBS@ @SDLMIXER_LIBS@ @SDLNET_LIBS@
EXTRA_DIST = \
chocolate_doom_icon.c \