summaryrefslogtreecommitdiff
path: root/textscreen/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2006-05-18 18:48:24 +0000
committerSimon Howard2006-05-18 18:48:24 +0000
commit978ddf539803405ab8fed17e21014ee1ae69fac8 (patch)
tree6f9cf3fe29ec11b9d7b008227061934fededc590 /textscreen/Makefile.am
parentff6493e0efe1c7ea628d8a6b596f915d9c9764e1 (diff)
downloadchocolate-doom-978ddf539803405ab8fed17e21014ee1ae69fac8.tar.gz
chocolate-doom-978ddf539803405ab8fed17e21014ee1ae69fac8.tar.bz2
chocolate-doom-978ddf539803405ab8fed17e21014ee1ae69fac8.zip
Initial working text-mode GUI framework.
Subversion-branch: /trunk/chocolate-doom Subversion-revision: 480
Diffstat (limited to 'textscreen/Makefile.am')
-rw-r--r--textscreen/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/textscreen/Makefile.am b/textscreen/Makefile.am
index 8894f0f4..2c7903f1 100644
--- a/textscreen/Makefile.am
+++ b/textscreen/Makefile.am
@@ -2,11 +2,18 @@
AM_CFLAGS = @SDL_CFLAGS@
noinst_LIBRARIES=libtextscreen.a
+bin_PROGRAMS=guitest
libtextscreen_a_SOURCES = \
txt_gui.c txt_gui.h \
txt_io.c txt_io.h \
txt_main.c txt_main.h \
+ txt_button.c txt_button.h \
+ txt_separator.c txt_separator.h\
+ txt_widget.c txt_widget.h \
+ txt_window.c txt_window.h \
txt_font.h
+guitest_LDADD = @SDL_LIBS@ libtextscreen.a
+guitest_SOURCES = guitest.c