summaryrefslogtreecommitdiff
path: root/textscreen/Makefile.am
diff options
context:
space:
mode:
authorSimon Howard2007-06-04 18:32:50 +0000
committerSimon Howard2007-06-04 18:32:50 +0000
commit9d7126c11b5f1577b00987b8d5f0f7f761b012d7 (patch)
treeb832c6f922879be3668d7f6720c3887ac4409f99 /textscreen/Makefile.am
parent2c4e3a7dbf89608355d1ce49c221d41b3e2fa7a8 (diff)
downloadchocolate-doom-9d7126c11b5f1577b00987b8d5f0f7f761b012d7.tar.gz
chocolate-doom-9d7126c11b5f1577b00987b8d5f0f7f761b012d7.tar.bz2
chocolate-doom-9d7126c11b5f1577b00987b8d5f0f7f761b012d7.zip
Rename txt_main.c to txt_sdl.c; add txt_sdl.h for SDL-specific API
functions, while keeping txt_main.h for the common API. Add TXT_SDL_SetEventCallback to allow programs to intercept SDL events in the textscreen main loop. Subversion-branch: /trunk/chocolate-doom Subversion-revision: 892
Diffstat (limited to 'textscreen/Makefile.am')
-rw-r--r--textscreen/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/textscreen/Makefile.am b/textscreen/Makefile.am
index 71989c3b..752e6361 100644
--- a/textscreen/Makefile.am
+++ b/textscreen/Makefile.am
@@ -15,12 +15,13 @@ libtextscreen_a_SOURCES = \
txt_gui.c txt_gui.h \
txt_inputbox.c txt_inputbox.h \
txt_io.c txt_io.h \
- txt_main.c txt_main.h \
+ txt_main.h \
txt_button.c txt_button.h \
txt_label.c txt_label.h \
txt_radiobutton.c txt_radiobutton.h \
txt_separator.c txt_separator.h \
txt_spinctrl.c txt_spinctrl.h \
+ txt_sdl.c txt_sdl.h \
txt_strut.c txt_strut.h \
txt_table.c txt_table.h \
txt_widget.c txt_widget.h \