summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 25 insertions, 25 deletions
diff --git a/configure.in b/configure.in
index 05ea5d61..f8482d53 100644
--- a/configure.in
+++ b/configure.in
@@ -1,11 +1,5 @@
AC_INIT(Chocolate Doom, 1.2.1, fraggle@gmail.com, chocolate-doom)
-PACKAGE_SHORTDESC="Conservative Doom source port"
-PACKAGE_COPYRIGHT="Copyright (C) 1993-2010"
-PACKAGE_LICENSE="GNU General Public License, version 2"
-PACKAGE_MAINTAINER="Simon Howard"
-PACKAGE_URL="http://www.chocolate-doom.org/"
-
AC_CONFIG_AUX_DIR(autotools)
orig_CFLAGS="$CFLAGS"
@@ -88,7 +82,7 @@ WINDOWS_CE=false
case "$host" in
*mingw32ce*|*cegcc*|*wince*)
- CFLAGS="-I../wince $CFLAGS"
+ CFLAGS="-I\$(top_builddir)/wince $CFLAGS"
WINDOWS_CE=true
;;
*)
@@ -105,6 +99,16 @@ AM_INIT_AUTOMAKE([1.8.0])
WINDOWS_RC_VERSION=`echo $PACKAGE_VERSION.0 | sed 's/\./, /g' `
+# This controls the prefix added to the start of program names. For example,
+# if this is changed to "lemon-", the programs generated will be named
+# lemon-doom, lemon-heretic, etc.
+
+PROGRAM_PREFIX=chocolate-
+
+AC_SUBST(PROGRAM_PREFIX)
+AC_DEFINE_UNQUOTED(PROGRAM_PREFIX, "$PROGRAM_PREFIX",
+ Change this when you create your awesome forked version)
+
AM_CONFIG_HEADER(config.h:config.hin)
AC_SUBST(WINDOWS_RC_VERSION)
@@ -116,32 +120,28 @@ AC_SUBST(SDLNET_LIBS)
AC_SUBST(ac_aux_dir)
-AC_SUBST(PACKAGE_SHORTDESC)
-AC_SUBST(PACKAGE_COPYRIGHT)
-AC_SUBST(PACKAGE_LICENSE)
-AC_SUBST(PACKAGE_MAINTAINER)
-AC_SUBST(PACKAGE_URL)
-AC_SUBST(PACKAGE_LONGDESC)
-
dnl Shut up the datarootdir warnings.
AC_DEFUN([AC_DATAROOTDIR_CHECKED])
AC_OUTPUT([
Makefile
-rpm.spec
+wince/Makefile
+textscreen/Makefile
+textscreen/examples/Makefile
man/Makefile
+src/Makefile
+src/doom/Makefile
+src/heretic/Makefile
+src/hexen/Makefile
+src/setup/Makefile
+src/strife/Makefile
pcsound/Makefile
pkg/Makefile
-pkg/config.make
-pkg/osx/Info.plist
-pkg/osx/Info-gnustep.plist
-setup/Makefile
-setup/setup-res.rc
-src/Makefile
-src/doom-screensaver.desktop
+pkg/wince/GNUmakefile
+pkg/win32/GNUmakefile
src/resource.rc
-textscreen/Makefile
-textscreen/examples/Makefile
-wince/Makefile
+src/setup-res.rc
+src/setup/setup-manifest.xml
+src/doom-screensaver.desktop
])