summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 23 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 0f4b48a0..e3287d00 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,11 @@
AC_INIT(Chocolate Doom, 1.2.1, fraggle@gmail.com, chocolate-doom)
+PACKAGE_SHORTDESC="Conservative Doom source port"
+PACKAGE_COPYRIGHT="Copyright (C) 1993-2010"
+PACKAGE_LICENSE="GNU General Public License, version 2"
+PACKAGE_MAINTAINER="Simon Howard"
+PACKAGE_URL="http://www.chocolate-doom.org/"
+
AC_CONFIG_AUX_DIR(autotools)
orig_CFLAGS="$CFLAGS"
@@ -120,27 +126,35 @@ AC_SUBST(SDLNET_LIBS)
AC_SUBST(ac_aux_dir)
+AC_SUBST(PACKAGE_SHORTDESC)
+AC_SUBST(PACKAGE_COPYRIGHT)
+AC_SUBST(PACKAGE_LICENSE)
+AC_SUBST(PACKAGE_MAINTAINER)
+AC_SUBST(PACKAGE_URL)
+
dnl Shut up the datarootdir warnings.
AC_DEFUN([AC_DATAROOTDIR_CHECKED])
AC_OUTPUT([
Makefile
-wince/Makefile
-textscreen/Makefile
-textscreen/examples/Makefile
man/Makefile
+pcsound/Makefile
+pkg/Makefile
+pkg/config.make
+pkg/osx/Info-gnustep.plist
+pkg/osx/Info.plist
+rpm.spec
src/Makefile
+src/doom-screensaver.desktop
src/doom/Makefile
src/heretic/Makefile
src/hexen/Makefile
-src/setup/Makefile
-pcsound/Makefile
-pkg/Makefile
-pkg/wince/GNUmakefile
-pkg/win32/GNUmakefile
src/resource.rc
src/setup-res.rc
+src/setup/Makefile
src/setup/setup-manifest.xml
-src/doom-screensaver.desktop
+textscreen/Makefile
+textscreen/examples/Makefile
+wince/Makefile
])