summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 19 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index c653f4e9..c100d7cf 100644
--- a/configure.in
+++ b/configure.in
@@ -95,7 +95,7 @@ WINDOWS_CE=false
case "$host" in
*mingw32ce*|*cegcc*|*wince*)
- CFLAGS="-I../wince $CFLAGS"
+ CFLAGS="-I\$(top_builddir)/wince $CFLAGS"
WINDOWS_CE=true
;;
*)
@@ -112,6 +112,16 @@ AM_INIT_AUTOMAKE([1.8.0])
WINDOWS_RC_VERSION=`echo $PACKAGE_VERSION.0 | sed 's/\./, /g' `
+# This controls the prefix added to the start of program names. For example,
+# if this is changed to "lemon-", the programs generated will be named
+# lemon-doom, lemon-heretic, etc.
+
+PROGRAM_PREFIX=chocolate-
+
+AC_SUBST(PROGRAM_PREFIX)
+AC_DEFINE_UNQUOTED(PROGRAM_PREFIX, "$PROGRAM_PREFIX",
+ Change this when you create your awesome forked version)
+
AM_CONFIG_HEADER(config.h:config.hin)
AC_SUBST(WINDOWS_RC_VERSION)
@@ -134,20 +144,24 @@ AC_DEFUN([AC_DATAROOTDIR_CHECKED])
AC_OUTPUT([
Makefile
-rpm.spec
man/Makefile
opl/Makefile
opl/examples/Makefile
pcsound/Makefile
pkg/Makefile
pkg/config.make
-pkg/osx/Info.plist
pkg/osx/Info-gnustep.plist
-setup/Makefile
-setup/setup-res.rc
+pkg/osx/Info.plist
+rpm.spec
src/Makefile
src/doom-screensaver.desktop
+src/doom/Makefile
+src/heretic/Makefile
+src/hexen/Makefile
src/resource.rc
+src/setup-res.rc
+src/setup/Makefile
+src/setup/setup-manifest.xml
textscreen/Makefile
textscreen/examples/Makefile
wince/Makefile