summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 60610ea1..0f4b48a0 100644
--- a/configure.in
+++ b/configure.in
@@ -82,7 +82,7 @@ WINDOWS_CE=false
case "$host" in
*mingw32ce*|*cegcc*|*wince*)
- CFLAGS="-I../wince $CFLAGS"
+ CFLAGS="-I\$(top_builddir)/wince $CFLAGS"
WINDOWS_CE=true
;;
*)
@@ -99,6 +99,16 @@ AM_INIT_AUTOMAKE([1.8.0])
WINDOWS_RC_VERSION=`echo $PACKAGE_VERSION.0 | sed 's/\./, /g' `
+# This controls the prefix added to the start of program names. For example,
+# if this is changed to "lemon-", the programs generated will be named
+# lemon-doom, lemon-heretic, etc.
+
+PROGRAM_PREFIX=chocolate-
+
+AC_SUBST(PROGRAM_PREFIX)
+AC_DEFINE_UNQUOTED(PROGRAM_PREFIX, "$PROGRAM_PREFIX",
+ Change this when you create your awesome forked version)
+
AM_CONFIG_HEADER(config.h:config.hin)
AC_SUBST(WINDOWS_RC_VERSION)
@@ -118,15 +128,19 @@ Makefile
wince/Makefile
textscreen/Makefile
textscreen/examples/Makefile
-setup/Makefile
man/Makefile
src/Makefile
+src/doom/Makefile
+src/heretic/Makefile
+src/hexen/Makefile
+src/setup/Makefile
pcsound/Makefile
pkg/Makefile
pkg/wince/GNUmakefile
pkg/win32/GNUmakefile
src/resource.rc
+src/setup-res.rc
+src/setup/setup-manifest.xml
src/doom-screensaver.desktop
-setup/setup-res.rc
])