summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am112
1 files changed, 99 insertions, 13 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 618c0bde..204e6c95 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,29 +1,115 @@
-MANPAGE_GEN_FILES=manpage.template docgen default.cfg.template extra.cfg.template
+MANPAGE_GEN_FILES = environ.man \
+ doom.template \
+ heretic.template \
+ hexen.template \
+ strife.template \
+ docgen \
+ default.cfg.template \
+ extra.cfg.template
-docdir=$(prefix)/share/doc/@PACKAGE@
+doomdocsdir = $(prefix)/share/doc/@PROGRAM_PREFIX@doom
+hereticdocsdir = $(prefix)/share/doc/@PROGRAM_PREFIX@heretic
+hexendocsdir = $(prefix)/share/doc/@PROGRAM_PREFIX@hexen
+strifedocsdir = $(prefix)/share/doc/@PROGRAM_PREFIX@strife
if HAVE_PYTHON
-man_MANS=chocolate-doom.6 \
- chocolate-server.6 \
- chocolate-setup.6 \
- default.cfg.5 \
- $(PACKAGE).cfg.5
+man_MANS = chocolate-server.6 \
+ chocolate-setup.6 \
+ chocolate-doom.6 \
+ default.cfg.5 \
+ chocolate-doom.cfg.5 \
+ chocolate-heretic.6 \
+ heretic.cfg.5 \
+ chocolate-heretic.cfg.5 \
+ chocolate-hexen.6 \
+ hexen.cfg.5 \
+ chocolate-hexen.cfg.5 \
+ chocolate-strife.6 \
+ strife.cfg.5 \
+ chocolate-strife.cfg.5
-nodist_doc_DATA=INSTALL
+doomdocs_DATA = INSTALL.doom CMDLINE.doom
+hereticdocs_DATA = INSTALL.heretic CMDLINE.heretic
+hexendocs_DATA = INSTALL.hexen CMDLINE.hexen
+strifedocs_DATA = INSTALL.strife CMDLINE.strife
chocolate-doom.6: ../src $(MANPAGE_GEN_FILES)
- ./docgen -m manpage.template ../src > $@
+ ./docgen -g doom -m doom.template ../src ../src/doom > $@
default.cfg.5: ../src default.cfg.template
- ./docgen -m default.cfg.template -c default.cfg ../src > $@
+ ./docgen -g doom -m default.cfg.template \
+ -c default ../src/m_config.c > $@
+
+chocolate-doom.cfg.5: ../src extra.cfg.template
+ ./docgen -g doom -m extra.cfg.template \
+ -c extended ../src/m_config.c > $@
+
+CMDLINE.doom : CMDLINE.template ../src ../src/doom
+ ./docgen -p CMDLINE.template ../src/ ../src/doom/ > $@
+
+INSTALL.doom: INSTALL.template
+ ./simplecpp -DDOOM -DPRECOMPILED < INSTALL.template > $@
+
+
+chocolate-heretic.6: ../src $(MANPAGE_GEN_FILES)
+ ./docgen -g heretic -m heretic.template ../src ../src/heretic > $@
+
+heretic.cfg.5: ../src default.cfg.template
+ ./docgen -g heretic -m default.cfg.template \
+ -c default ../src/m_config.c > $@
+
+chocolate-heretic.cfg.5: ../src extra.cfg.template
+ ./docgen -g heretic -m extra.cfg.template \
+ -c extended ../src/m_config.c > $@
+
+CMDLINE.heretic : CMDLINE.template ../src ../src/heretic
+ ./docgen -p CMDLINE.template ../src/ ../src/heretic/ > $@
+
+INSTALL.heretic: INSTALL.template
+ ./simplecpp -DHERETIC -DPRECOMPILED < INSTALL.template > $@
+
+
+chocolate-hexen.6: ../src $(MANPAGE_GEN_FILES)
+ ./docgen -g hexen -m hexen.template ../src ../src/hexen > $@
+
+hexen.cfg.5: ../src default.cfg.template
+ ./docgen -g hexen -m default.cfg.template \
+ -c default ../src/m_config.c > $@
+
+chocolate-hexen.cfg.5: ../src extra.cfg.template
+ ./docgen -g hexen -m extra.cfg.template \
+ -c extended ../src/m_config.c > $@
+
+CMDLINE.hexen : CMDLINE.template ../src ../src/hexen
+ ./docgen -p CMDLINE.template ../src/ ../src/hexen/ > $@
+
+INSTALL.hexen: INSTALL.template
+ ./simplecpp -DHEXEN -DPRECOMPILED < INSTALL.template > $@
+
+
+chocolate-strife.6: ../src $(MANPAGE_GEN_FILES)
+ ./docgen -g strife -m strife.template ../src ../src/strife > $@
+
+strife.cfg.5: ../src default.cfg.template
+ ./docgen -g strife -m default.cfg.template \
+ -c default ../src/m_config.c > $@
+
+chocolate-strife.cfg.5: ../src extra.cfg.template
+ ./docgen -g strife -m extra.cfg.template \
+ -c extended ../src/m_config.c > $@
+
+CMDLINE.strife : CMDLINE.template ../src ../src/strife
+ ./docgen -p CMDLINE.template ../src/ ../src/strife/ > $@
+
+INSTALL.strife: INSTALL.template
+ ./simplecpp -DSTRIFE -DPRECOMPILED < INSTALL.template > $@
-$(PACKAGE).cfg.5: ../src extra.cfg.template
- ./docgen -m extra.cfg.template -c $(PACKAGE).cfg ../src > $@
INSTALL: INSTALL.template
- ./simplecpp -DPRECOMPILED < INSTALL.template > $@
+ ./simplecpp -DDOOM -DHERETIC -DHEXEN -DSTRIFE \
+ -DPRECOMPILED < INSTALL.template > $@
endif