summaryrefslogtreecommitdiff
path: root/pkg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/Makefile.am')
-rw-r--r--pkg/Makefile.am34
1 files changed, 33 insertions, 1 deletions
diff --git a/pkg/Makefile.am b/pkg/Makefile.am
index 66cb9ba0..63da8f53 100644
--- a/pkg/Makefile.am
+++ b/pkg/Makefile.am
@@ -1,3 +1,35 @@
-DIST_SUBDIRS=wince win32
+OSX_FILES= \
+osx/Resources/128x128.png \
+osx/Resources/app.icns \
+osx/Resources/app.png \
+osx/Resources/wadfile.icns \
+osx/Resources/wadfile.png \
+osx/Resources/launcher.nib/classes.nib \
+osx/Resources/launcher.nib/info.nib \
+osx/Resources/launcher.nib/keyedobjects.nib \
+osx/GNUmakefile \
+osx/Info.plist.in osx/Info-gnustep.plist.in \
+osx/PkgInfo \
+osx/cp-with-libs \
+osx/main.m \
+osx/AppController.m osx/AppController.h \
+osx/Execute.m osx/Execute.h \
+osx/IWADController.m osx/IWADController.h \
+osx/IWADLocation.m osx/IWADLocation.h \
+osx/LauncherManager.m osx/LauncherManager.h
+
+WINCE_FILES= \
+wince/GNUmakefile \
+wince/common.py \
+wince/doom-cab.cfg \
+wince/heretic-cab.cfg \
+wince/hexen-cab.cfg \
+wince/wince-cabgen
+
+WIN32_FILES= \
+win32/GNUmakefile \
+win32/README
+
+EXTRA_DIST=$(OSX_FILES) $(WINCE_FILES) $(WIN32_FILES)