summaryrefslogtreecommitdiff
path: root/pkg/wince/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/wince/Makefile.am')
-rw-r--r--pkg/wince/Makefile.am30
1 files changed, 25 insertions, 5 deletions
diff --git a/pkg/wince/Makefile.am b/pkg/wince/Makefile.am
index 13b48d2e..a203e63c 100644
--- a/pkg/wince/Makefile.am
+++ b/pkg/wince/Makefile.am
@@ -1,10 +1,30 @@
-DEPS=$(shell ./wince-cabgen -d $(CONFIG_FILE))
-CONFIG_FILE=wince-cab.cfg
-OUTPUT_FILE=@PACKAGE_TARNAME@-@PACKAGE_VERSION@.cab
+# Doom:
-noinst_DATA = $(OUTPUT_FILE)
+DOOM_CAB=chocolate-doom-@PACKAGE_VERSION@.cab
+DOOM_CFG=doom-cab.cfg
+DOOM_DEPS=$(shell ./wince-cabgen -d $(DOOM_CFG))
-$(OUTPUT_FILE) : $(CONFIG_FILE) $(DEPS)
+$(DOOM_CAB) : $(DOOM_CFG) $(DOOM_DEPS)
./wince-cabgen $< $@
+# Heretic:
+
+HERETIC_CAB=chocolate-heretic-@PACKAGE_VERSION@.cab
+HERETIC_CFG=heretic-cab.cfg
+HERETIC_DEPS=$(shell ./wince-cabgen -d $(HERETIC_CFG))
+
+$(HERETIC_CAB) : $(HERETIC_CFG) $(HERETIC_DEPS)
+ ./wince-cabgen $< $@
+
+# Hexen:
+
+HEXEN_CAB=chocolate-hexen-@PACKAGE_VERSION@.cab
+HEXEN_CFG=hexen-cab.cfg
+HEXEN_DEPS=$(shell ./wince-cabgen -d $(HEXEN_CFG))
+
+$(HEXEN_CAB) : $(HEXEN_CFG) $(HEXEN_DEPS)
+ ./wince-cabgen $< $@
+
+noinst_DATA = $(DOOM_CAB) $(HERETIC_CAB) $(HEXEN_CAB)
+