summaryrefslogtreecommitdiff
path: root/setup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'setup/Makefile.am')
-rw-r--r--setup/Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/setup/Makefile.am b/setup/Makefile.am
deleted file mode 100644
index 91c7449a..00000000
--- a/setup/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-
-gamesdir = $(prefix)/games
-
-AM_CFLAGS = -I../textscreen -I../src @SDLMIXER_CFLAGS@
-
-games_PROGRAMS = chocolate-setup
-
-SOURCE_FILES = \
- compatibility.c compatibility.h \
- configfile.c configfile.h \
- display.c display.h \
- joystick.c joystick.h \
- keyboard.c keyboard.h \
- m_argv.c m_argv.h \
- mainmenu.c \
- mouse.c mouse.h \
- multiplayer.c multiplayer.h \
- sound.c sound.h \
- execute.c execute.h \
- txt_joybinput.c txt_joybinput.h \
- txt_keyinput.c txt_keyinput.h \
- txt_mouseinput.c txt_mouseinput.h
-
-EXTRA_DIST= \
- setup_icon.c \
- setup-manifest.xml
-
-if HAVE_WINDRES
-chocolate_setup_SOURCES=$(SOURCE_FILES) setup-res.rc
-else
-chocolate_setup_SOURCES=$(SOURCE_FILES)
-endif
-
-chocolate_setup_LDADD = \
- ../wince/libc_wince.a \
- ../textscreen/libtextscreen.a \
- @SDLMIXER_LIBS@ \
- @LDFLAGS@
-
-.rc.o:
- $(WINDRES) $^ -o $@
-%.o : %.rc
- $(WINDRES) $^ -o $@
-
-if HAVE_PYTHON
-
-setup_icon.c : ../data/setup8.ico
- ../data/convert-icon $^ $@
-
-endif
-