summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5c9d15f4..0b831922 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,14 +7,13 @@ execgames_PROGRAMS = @PROGRAM_PREFIX@doom \
@PROGRAM_PREFIX@heretic \
@PROGRAM_PREFIX@hexen \
@PROGRAM_PREFIX@strife \
- @PROGRAM_PREFIX@server
+ @PROGRAM_PREFIX@server \
+ @PROGRAM_PREFIX@setup
-noinst_PROGRAMS = @PROGRAM_PREFIX@setup
-
-SETUP_BINARIES = @PROGRAM_PREFIX@doom-setup$(EXEEXT) \
- @PROGRAM_PREFIX@heretic-setup$(EXEEXT) \
- @PROGRAM_PREFIX@hexen-setup$(EXEEXT) \
- @PROGRAM_PREFIX@strife-setup$(EXEEXT)
+SETUP_BINARIES = @PROGRAM_PREFIX@doom-setup \
+ @PROGRAM_PREFIX@heretic-setup \
+ @PROGRAM_PREFIX@hexen-setup \
+ @PROGRAM_PREFIX@strife-setup
execgames_SCRIPTS = $(SETUP_BINARIES)
@@ -184,8 +183,8 @@ endif
@PROGRAM_PREFIX@strife_LDADD = strife/libstrife.a $(EXTRA_LIBS)
-$(SETUP_BINARIES): @PROGRAM_PREFIX@setup$(EXEEXT)
- cp $< $@
+$(SETUP_BINARIES): @PROGRAM_PREFIX@setup
+ $(LN_S) $< $@
# Source files needed for chocolate-setup: