summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 54450e78..2ba6dbef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,11 +1,12 @@
-SUBDIRS=doom heretic hexen setup
+SUBDIRS=doom heretic hexen strife setup
gamesdir = $(prefix)/games
games_PROGRAMS = @PROGRAM_PREFIX@doom \
@PROGRAM_PREFIX@heretic \
@PROGRAM_PREFIX@hexen \
+ @PROGRAM_PREFIX@strife \
@PROGRAM_PREFIX@server \
@PROGRAM_PREFIX@setup
@@ -164,6 +165,14 @@ endif
@PROGRAM_PREFIX@hexen_LDADD = hexen/libhexen.a $(EXTRA_LIBS)
+if HAVE_WINDRES
+@PROGRAM_PREFIX@strife_SOURCES=$(SOURCE_FILES_WITH_DEH) resource.rc
+else
+@PROGRAM_PREFIX@strife_SOURCES=$(SOURCE_FILES_WITH_DEH)
+endif
+
+@PROGRAM_PREFIX@strife_LDADD = strife/libstrife.a $(EXTRA_LIBS)
+
# Source files needed for chocolate-setup:
SETUP_FILES= \