summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1e54824c..78ee3bae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -217,6 +217,25 @@ EXTRA_DIST = \
doom-screensaver.desktop.in \
manifest.xml
+appdatadir = $(prefix)/share/appdata
+appdata_DATA = \
+ @PROGRAM_PREFIX@doom.appdata.xml \
+ @PROGRAM_PREFIX@heretic.appdata.xml \
+ @PROGRAM_PREFIX@hexen.appdata.xml \
+ @PROGRAM_PREFIX@strife.appdata.xml
+
+@PROGRAM_PREFIX@doom.appdata.xml : doom.appdata.xml
+ cp doom.appdata.xml $@
+
+@PROGRAM_PREFIX@heretic.appdata.xml : heretic.appdata.xml
+ cp heretic.appdata.xml $@
+
+@PROGRAM_PREFIX@hexen.appdata.xml : hexen.appdata.xml
+ cp hexen.appdata.xml $@
+
+@PROGRAM_PREFIX@strife.appdata.xml : strife.appdata.xml
+ cp strife.appdata.xml $@
+
appdir = $(prefix)/share/applications
app_DATA = \
@PROGRAM_PREFIX@doom.desktop \