summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0b831922..5c9d15f4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,13 +7,14 @@ execgames_PROGRAMS = @PROGRAM_PREFIX@doom \
@PROGRAM_PREFIX@heretic \
@PROGRAM_PREFIX@hexen \
@PROGRAM_PREFIX@strife \
- @PROGRAM_PREFIX@server \
- @PROGRAM_PREFIX@setup
+ @PROGRAM_PREFIX@server
-SETUP_BINARIES = @PROGRAM_PREFIX@doom-setup \
- @PROGRAM_PREFIX@heretic-setup \
- @PROGRAM_PREFIX@hexen-setup \
- @PROGRAM_PREFIX@strife-setup
+noinst_PROGRAMS = @PROGRAM_PREFIX@setup
+
+SETUP_BINARIES = @PROGRAM_PREFIX@doom-setup$(EXEEXT) \
+ @PROGRAM_PREFIX@heretic-setup$(EXEEXT) \
+ @PROGRAM_PREFIX@hexen-setup$(EXEEXT) \
+ @PROGRAM_PREFIX@strife-setup$(EXEEXT)
execgames_SCRIPTS = $(SETUP_BINARIES)
@@ -183,8 +184,8 @@ endif
@PROGRAM_PREFIX@strife_LDADD = strife/libstrife.a $(EXTRA_LIBS)
-$(SETUP_BINARIES): @PROGRAM_PREFIX@setup
- $(LN_S) $< $@
+$(SETUP_BINARIES): @PROGRAM_PREFIX@setup$(EXEEXT)
+ cp $< $@
# Source files needed for chocolate-setup: