summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am118
1 files changed, 41 insertions, 77 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e43cb7f0..820c9d64 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,12 +1,16 @@
+SUBDIRS=doom heretic hexen
+
gamesdir = $(prefix)/games
+EXTRA_PROGRAMS = chocolate-heretic chocolate-hexen
games_PROGRAMS = chocolate-doom chocolate-server
-AM_CFLAGS = -I../textscreen -I../pcsound @SDL_CFLAGS@ @SDLMIXER_CFLAGS@ @SDLNET_CFLAGS@
+AM_CFLAGS = -Idoom -I../textscreen -I../pcsound @SDL_CFLAGS@ @SDLMIXER_CFLAGS@ @SDLNET_CFLAGS@ -Werror
DEDSERV_FILES=\
d_dedicated.c \
+d_mode.c d_mode.h \
i_main.c \
i_timer.c i_timer.h \
m_argv.c m_argv.h \
@@ -24,34 +28,18 @@ chocolate_server_SOURCES=$(DEDSERV_FILES)
chocolate_server_LDADD = @LDFLAGS@ @SDL_LIBS@ @SDLNET_LIBS@
MAIN_SOURCE_FILES=\
-am_map.c am_map.h \
-d_englsh.h \
-d_event.h \
-d_items.c d_items.h \
-d_iwad.c d_iwad.h \
-d_main.c d_main.h \
-d_net.c d_net.h \
-doomdata.h \
-doomdef.c doomdef.h \
-doomkeys.h \
-doomfeatures.h \
-doomstat.c doomstat.h \
-doomtype.h \
-d_player.h \
-dstrings.c dstrings.h \
-d_textur.h \
-d_think.h \
-d_ticcmd.h \
-f_finale.c f_finale.h \
-f_wipe.c f_wipe.h \
-g_game.c g_game.h \
-hu_lib.c hu_lib.h \
-hu_stuff.c hu_stuff.h \
+d_event.c d_event.h \
+ doomkeys.h \
+ doomfeatures.h \
+ doomtype.h \
+d_mode.c d_mode.h \
+ d_ticcmd.h \
+i_cdmus.c i_cdmus.h \
i_main.c \
-info.c info.h \
i_joystick.c i_joystick.h \
i_scale.c i_scale.h \
i_swap.h \
+i_sound.c i_sound.h \
i_system.c i_system.h \
i_timer.c i_timer.h \
i_video.c i_video.h \
@@ -59,50 +47,14 @@ m_argv.c m_argv.h \
m_bbox.c m_bbox.h \
m_cheat.c m_cheat.h \
m_config.c m_config.h \
+m_controls.c m_controls.h \
m_fixed.c m_fixed.h \
-m_menu.c m_menu.h \
m_misc.c m_misc.h \
md5.c md5.h \
memio.c memio.h \
-m_random.c m_random.h \
-p_ceilng.c \
-p_doors.c \
-p_enemy.c \
-p_floor.c \
-p_inter.c p_inter.h \
-p_lights.c \
-p_local.h \
-p_map.c \
-p_maputl.c \
-p_mobj.c p_mobj.h \
-p_plats.c \
-p_pspr.c p_pspr.h \
-p_saveg.c p_saveg.h \
-p_setup.c p_setup.h \
-p_sight.c \
-p_spec.c p_spec.h \
-p_switch.c \
-p_telept.c \
-p_tick.c p_tick.h \
-p_user.c \
-r_bsp.c r_bsp.h \
-r_data.c r_data.h \
-r_defs.h \
-r_draw.c r_draw.h \
-r_local.h \
-r_main.c r_main.h \
-r_plane.c r_plane.h \
-r_segs.c r_segs.h \
-r_sky.c r_sky.h \
-r_state.h \
-r_things.c r_things.h \
-sounds.c sounds.h \
-s_sound.c s_sound.h \
-st_lib.c st_lib.h \
-st_stuff.c st_stuff.h \
tables.c tables.h \
v_video.c v_video.h \
-wi_stuff.c wi_stuff.h \
+ v_patch.h \
w_checksum.c w_checksum.h \
w_wad.c w_wad.h \
w_file.c w_file.h \
@@ -114,19 +66,7 @@ z_zone.c z_zone.h
# source files needed for FEATURE_DEHACKED
FEATURE_DEHACKED_SOURCE_FILES= \
-deh_ammo.c \
-deh_cheat.c \
-deh_defs.h \
-deh_frame.c \
-deh_io.c deh_io.h \
-deh_main.c deh_main.h \
-deh_mapping.c deh_mapping.h \
-deh_misc.c deh_misc.h \
-deh_ptr.c \
-deh_sound.c \
-deh_text.c \
-deh_thing.c \
-deh_weapon.c
+deh_str.c deh_str.h
# source files needed for FEATURE_MULTIPLAYER
@@ -163,13 +103,37 @@ SOURCE_FILES = $(MAIN_SOURCE_FILES) \
$(FEATURE_WAD_MERGE_SOURCE_FILES) \
$(FEATURE_SOUND_SOURCE_FILES)
+EXTRA_LIBS = \
+ ../textscreen/libtextscreen.a \
+ ../pcsound/libpcsound.a \
+ @LDFLAGS@ \
+ @SDL_LIBS@ \
+ @SDLMIXER_LIBS@ \
+ @SDLNET_LIBS@
+
if HAVE_WINDRES
chocolate_doom_SOURCES=$(SOURCE_FILES) resource.rc
else
chocolate_doom_SOURCES=$(SOURCE_FILES)
endif
-chocolate_doom_LDADD = ../textscreen/libtextscreen.a ../pcsound/libpcsound.a @LDFLAGS@ @SDL_LIBS@ @SDLMIXER_LIBS@ @SDLNET_LIBS@
+chocolate_doom_LDADD = doom/libdoom.a $(EXTRA_LIBS)
+
+if HAVE_WINDRES
+chocolate_heretic_SOURCES=$(SOURCE_FILES) resource.rc
+else
+chocolate_heretic_SOURCES=$(SOURCE_FILES)
+endif
+
+chocolate_heretic_LDADD = heretic/libheretic.a $(EXTRA_LIBS)
+
+if HAVE_WINDRES
+chocolate_hexen_SOURCES=$(SOURCE_FILES) resource.rc
+else
+chocolate_hexen_SOURCES=$(SOURCE_FILES)
+endif
+
+chocolate_hexen_LDADD = hexen/libhexen.a $(EXTRA_LIBS)
EXTRA_DIST = \
icon.c \