summaryrefslogtreecommitdiff
path: root/src/heretic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/heretic/Makefile.am')
-rw-r--r--src/heretic/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/heretic/Makefile.am b/src/heretic/Makefile.am
index 2a2f8245..3fdd3ff7 100644
--- a/src/heretic/Makefile.am
+++ b/src/heretic/Makefile.am
@@ -55,5 +55,14 @@ EXTRA_DIST= \
i_sound.c \
i_ibm.c
-libheretic_a_SOURCES=$(SOURCE_FILES)
+FEATURE_DEHACKED_SOURCE_FILES = \
+deh_ammo.c \
+deh_frame.c \
+deh_htic.c \
+deh_sound.c \
+deh_thing.c \
+deh_weapon.c
+
+libheretic_a_SOURCES=$(SOURCE_FILES) \
+ $(FEATURE_DEHACKED_SOURCE_FILES)