summaryrefslogtreecommitdiff
path: root/src/setup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/setup/Makefile.am')
-rw-r--r--src/setup/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/setup/Makefile.am b/src/setup/Makefile.am
new file mode 100644
index 00000000..6028eab7
--- /dev/null
+++ b/src/setup/Makefile.am
@@ -0,0 +1,25 @@
+
+AM_CFLAGS = @SDL_CFLAGS@ -I../../textscreen -I.. -DINSTALL_DIR="\"$(gamesdir)\""
+
+noinst_LIBRARIES = libsetup.a
+
+SOURCE_FILES = \
+ compatibility.c compatibility.h \
+ display.c display.h \
+ joystick.c joystick.h \
+ keyboard.c keyboard.h \
+ mainmenu.c \
+ mouse.c mouse.h \
+ multiplayer.c multiplayer.h \
+ sound.c sound.h \
+ execute.c execute.h \
+ txt_joybinput.c txt_joybinput.h \
+ txt_keyinput.c txt_keyinput.h \
+ txt_mouseinput.c txt_mouseinput.h
+
+libsetup_a_SOURCES = $(SOURCE_FILES)
+
+EXTRA_DIST= \
+ setup_icon.c \
+ setup-manifest.xml
+