aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ef299f..8c2a26c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,9 +1,18 @@
cmake_minimum_required(VERSION 2.8)
option(PANDORA "Set to ON if targeting an OpenPandora device" ${PANDORA})
+option(PYRA "Set to ON if targeting an DragonBox Pyra device" ${PANDORA})
+option(CHIP "Set to ON if targeting an PocketCHIP device" ${PANDORA})
+
if(PANDORA)
- add_definitions(-DPANDORA -DARM -DNEON)
+ add_definitions(-DPANDORA)
+endif()
+if(PYRA)
+ add_definitions(-DPYRA)
+endif()
+if(CHIP)
+ add_definitions(-DCHIP)
endif()
#create a _SDL2 later?