aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authornotaz2010-11-16 18:39:07 +0200
committernotaz2010-11-17 00:58:09 +0200
commitaa1fc44b4532dc68be2482730a275f8a3ba8a039 (patch)
tree95f1ec936aa776158f8b76e805eb0c1eafe473b0 /debian/rules
parentef79bbde537d6b9c745a7d86cb9df1d04c35590d (diff)
downloadpcsx_rearmed-aa1fc44b4532dc68be2482730a275f8a3ba8a039.tar.gz
pcsx_rearmed-aa1fc44b4532dc68be2482730a275f8a3ba8a039.tar.bz2
pcsx_rearmed-aa1fc44b4532dc68be2482730a275f8a3ba8a039.zip
remove stuff we won't need
this makes the source tree more pleasant to work with.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules75
1 files changed, 0 insertions, 75 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 8645846..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-#export DH_VERBOSE=1
-
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2 -fomit-frame-pointer
-endif
-
-CONFIGURE_PARAM = \
- --host=$(DEB_HOST_GNU_TYPE) \
- --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr \
- --bindir=/usr/games \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- --enable-opengl
-
-config.status: configure
- dh_testdir
- CFLAGS="$(CFLAGS)" ./configure $(CONFIGURE_PARAM)
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- [ ! -f Makefile ] || make distclean
-
- dh_clean config.status config.log po/stamp-po
-
-install: build
- dh_testdir
- dh_testroot
- dh_installdirs
- $(MAKE) install DESTDIR=$(CURDIR)/debian/pcsxr
- # Remove useless files
- rm -f $(CURDIR)/debian/pcsxr/usr/lib/games/psemu/*.la
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installmenu
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_makeshlibs
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install