aboutsummaryrefslogtreecommitdiff
path: root/debian_maemo/buildpkg
diff options
context:
space:
mode:
authorPaolo Iommarini2013-02-17 13:39:48 +0100
committerPaolo Iommarini2013-02-17 13:39:48 +0100
commit029295b0790609debb9e9d6c093627db696388a4 (patch)
tree2c27b3b1fd435a874a7c04adee1de0b4f25368be /debian_maemo/buildpkg
parenta76fd9535db9b36dd4d8f2e6bc9d804db807907f (diff)
downloadpcsx_rearmed-029295b0790609debb9e9d6c093627db696388a4.tar.gz
pcsx_rearmed-029295b0790609debb9e9d6c093627db696388a4.tar.bz2
pcsx_rearmed-029295b0790609debb9e9d6c093627db696388a4.zip
Added debian_maemo to build the maemo package
Diffstat (limited to 'debian_maemo/buildpkg')
-rw-r--r--debian_maemo/buildpkg13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian_maemo/buildpkg b/debian_maemo/buildpkg
new file mode 100644
index 0000000..4c34f94
--- /dev/null
+++ b/debian_maemo/buildpkg
@@ -0,0 +1,13 @@
+#!/bin/bash -e
+
+NAME=`head debian/changelog -n1 | sed -n 's/^\(.*\) (\(.*\)) .*/\1-\2/p'`
+[[ -z $NAME ]] && { echo "Could not extract package name and version from debian/changelog" 2>&1; exit 1; }
+
+rm -rf ../$NAME
+cp -r ../`basename $PWD` ../$NAME
+cd ../$NAME
+rm -rf .git*
+find . -depth -name .svn -type d -exec rm -r {} \;
+find . -name '*~' -exec rm {} \;
+
+LD_LIBRARY_PATH=/usr/lib dpkg-buildpackage -rfakeroot $*