aboutsummaryrefslogtreecommitdiff
path: root/debian_maemo/rules
diff options
context:
space:
mode:
authorTwinaphex2017-04-09 15:34:17 +0200
committerGitHub2017-04-09 15:34:17 +0200
commitd4fa7f640a5f6cc014ee74912ec0b1dd5e19abad (patch)
tree1ae12cf02ccb4819268b19de7dc70fc09d9ce63f /debian_maemo/rules
parent0b52c77bc1caaa56b91222e4836e6c85a5f2b52a (diff)
parent646a63e41c53e5c1c971a4e305d4627dcee43c5e (diff)
downloadpcsx_rearmed-d4fa7f640a5f6cc014ee74912ec0b1dd5e19abad.tar.gz
pcsx_rearmed-d4fa7f640a5f6cc014ee74912ec0b1dd5e19abad.tar.bz2
pcsx_rearmed-d4fa7f640a5f6cc014ee74912ec0b1dd5e19abad.zip
Merge pull request #113 from meepingsnesroms/master
Remove outdated platforms
Diffstat (limited to 'debian_maemo/rules')
-rw-r--r--debian_maemo/rules68
1 files changed, 0 insertions, 68 deletions
diff --git a/debian_maemo/rules b/debian_maemo/rules
deleted file mode 100644
index 5230bf7..0000000
--- a/debian_maemo/rules
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-#export DH_VERBOSE=1
-
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-
-#GAME_VERSION := $(shell head debian/changelog -n1 | sed -n 's/.* (\(.*\)) .*/\1/p')
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-build: build-stamp
-
-build-stamp:
- dh_testdir
- ./configure --platform=maemo --gpu=neon --sound-drivers=pulseaudio --enable-neon
- $(MAKE)
- strip pcsx
- strip plugins/gpu_unai/gpu_unai.so
- strip plugins/gpu-gles/gpu_gles.so
- strip plugins/spunull/spunull.so
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- dh_clean
- $(MAKE) clean clean_plugins
-
-install: build
- dh_testdir
- dh_testroot
- dh_installdirs
- mkdir -p "$(CURDIR)"/debian/pcsxrearmed/opt/maemo/usr/games/screenshots
- chmod 777 "$(CURDIR)"/debian/pcsxrearmed/opt/maemo/usr/games/screenshots
- chown user "$(CURDIR)"/debian/pcsxrearmed/opt/maemo/usr/games/screenshots
- dh_install
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- #dh_installmenu
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_makeshlibs
- dh_shlibdeps
- dh_gencontrol
- #maemo-optify
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install