aboutsummaryrefslogtreecommitdiff
path: root/deps/mman/CMakeLists.txt
diff options
context:
space:
mode:
authorTwinaphex2020-02-08 16:24:22 +0100
committerGitHub2020-02-08 16:24:22 +0100
commit0adc619b5a5705d16cc6caea64951776ababbb96 (patch)
treefbae9b1d18d04d8e7908aa1c3446782ebf6e8785 /deps/mman/CMakeLists.txt
parent0204c39a68a1fd4bf667aa8ece5a769f2983b7d0 (diff)
parent6f1edc3c7fd1f7f58155107d0c99d0ac7d22443b (diff)
downloadpcsx_rearmed-0adc619b5a5705d16cc6caea64951776ababbb96.tar.gz
pcsx_rearmed-0adc619b5a5705d16cc6caea64951776ababbb96.tar.bz2
pcsx_rearmed-0adc619b5a5705d16cc6caea64951776ababbb96.zip
Merge pull request #377 from pcercuei/libretro
Lightrec dynarec
Diffstat (limited to 'deps/mman/CMakeLists.txt')
-rw-r--r--deps/mman/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/deps/mman/CMakeLists.txt b/deps/mman/CMakeLists.txt
new file mode 100644
index 0000000..72b9c26
--- /dev/null
+++ b/deps/mman/CMakeLists.txt
@@ -0,0 +1,33 @@
+project (mman-win32 C)
+
+cmake_minimum_required (VERSION 2.8)
+
+option (BUILD_SHARED_LIBS "shared/static libs" ON)
+option (BUILD_TESTS "tests?" OFF)
+
+set (headers mman.h)
+set (sources mman.c)
+
+add_library (mman ${sources})
+
+if (BUILD_SHARED_LIBS)
+ target_compile_definitions(mman
+ PUBLIC MMAN_LIBRARY_DLL
+ PRIVATE MMAN_LIBRARY
+ )
+endif()
+
+install (TARGETS mman RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+
+install (FILES ${headers} DESTINATION include/sys)
+
+if (BUILD_TESTS)
+ enable_testing ()
+ add_executable (t_mman test.c)
+ target_link_libraries (t_mman mman)
+ add_test (NAME t_mman COMMAND t_mman${CMAKE_EXECUTABLE_SUFFIX})
+endif ()
+
+