aboutsummaryrefslogtreecommitdiff
path: root/deps/mman/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Cercueil2020-01-30 20:18:58 -0300
committerPaul Cercueil2020-02-08 11:44:52 -0300
commit81c4586ff05b003fc65201c3e4504738996d6412 (patch)
tree82529cafd6b659e63c93765a6ca38c7c4a662607 /deps/mman/CMakeLists.txt
parentd16005f843cd28ae90f091bd4e39a90b355e1d45 (diff)
downloadpcsx_rearmed-81c4586ff05b003fc65201c3e4504738996d6412.tar.gz
pcsx_rearmed-81c4586ff05b003fc65201c3e4504738996d6412.tar.bz2
pcsx_rearmed-81c4586ff05b003fc65201c3e4504738996d6412.zip
git subrepo clone (merge) https://github.com/witwall/mman-win32 deps/mman
subrepo: subdir: "deps/mman" merged: "2d1c576e" upstream: origin: "https://github.com/witwall/mman-win32" branch: "master" commit: "2d1c576e" git-subrepo: version: "0.4.1" origin: "https://github.com/ingydotnet/git-subrepo.git" commit: "a04d8c2"
Diffstat (limited to 'deps/mman/CMakeLists.txt')
-rw-r--r--deps/mman/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/deps/mman/CMakeLists.txt b/deps/mman/CMakeLists.txt
new file mode 100644
index 0000000..72b9c26
--- /dev/null
+++ b/deps/mman/CMakeLists.txt
@@ -0,0 +1,33 @@
+project (mman-win32 C)
+
+cmake_minimum_required (VERSION 2.8)
+
+option (BUILD_SHARED_LIBS "shared/static libs" ON)
+option (BUILD_TESTS "tests?" OFF)
+
+set (headers mman.h)
+set (sources mman.c)
+
+add_library (mman ${sources})
+
+if (BUILD_SHARED_LIBS)
+ target_compile_definitions(mman
+ PUBLIC MMAN_LIBRARY_DLL
+ PRIVATE MMAN_LIBRARY
+ )
+endif()
+
+install (TARGETS mman RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+
+install (FILES ${headers} DESTINATION include/sys)
+
+if (BUILD_TESTS)
+ enable_testing ()
+ add_executable (t_mman test.c)
+ target_link_libraries (t_mman mman)
+ add_test (NAME t_mman COMMAND t_mman${CMAKE_EXECUTABLE_SUFFIX})
+endif ()
+
+