aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBastien Nocera2002-05-10 17:28:09 +0000
committerBastien Nocera2002-05-10 17:28:09 +0000
commit1187b8fd37d1b02be864458f1e8ff4c2d7404108 (patch)
tree13e4afd4b0467fcbc3e96f897d018cc6d01a1a0f /debian/rules
parent5502291f7ade4d3ec903bc8c632328391179378d (diff)
downloadscummvm-rg350-1187b8fd37d1b02be864458f1e8ff4c2d7404108.tar.gz
scummvm-rg350-1187b8fd37d1b02be864458f1e8ff4c2d7404108.tar.bz2
scummvm-rg350-1187b8fd37d1b02be864458f1e8ff4c2d7404108.zip
- removed the old debian files, added new more correct ones, can be used to generate packages from releases and CVS. Just run the debian/prepare script beforehand. Do NOT modify the debian/changelog.debian file.
svn-id: r4267
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules65
1 files changed, 0 insertions, 65 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 3cce726d34..0000000000
--- a/debian/rules
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
-export DH_COMPAT=3
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
- dh_testdir
- $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
- -$(MAKE) clean
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- cp scummvm debian/scummvm/usr/bin
- cp scummvm.6 debian/scummvm/usr/share/man/man6
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
-# dh_installdebconf
- dh_installdocs
- dh_installmenu
- dh_installman
-# dh_undocumented
- dh_installchangelogs
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_makeshlibs
- dh_installdeb
-# dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure